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UCAM Main Window 
When you start UCAM, the Main Window appears with an empty main drawing area. The title bar of this the main 
window displays the version and subversion number of UCAM that you are currently working with.  
The screenshot below displays the main drawing area with a loaded job.  
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Job menu 

New… 

 

 
Name 
This is the Ucam job name. 
 
Revision 
Enter here the revision number of the PCB. 
 
Customer 
This is the name of the customer job. 
 
Size 
Displays the X and Y size of the PCB. 
 
Path 
Directory path where you want to save the Job file on the hard disk. 
 
Checklist 
Link checklist to the job. 
 
Info 
Displays information related to the job. 
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Open… 

 
 
Open an existing Ucam job. 

Edit… 
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Merge… 

 
 
Use this dialog box to add the data of another existing job to the current job. 
 
Layer  
Merges the layers of class LAYER. 
 
Drill 
 Merges the layers of class DRILL. 
 
Extra 
Merges the layers of class EXTRA. 

Parameters… 

The Parameters dialog box is identical to the Job Definition dialog box displayed after choosing New… from the Job 
menu (See above). 

Save v3 

Save the current job using DPF version 3 format. 
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Save As… 
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SmartStart… 

 

 

Use this dialog box to add data files to the current job. The SmartStart dialog box contains a list of files in the job 
directory. 
 

Add Files 
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Graphical Aperture Reader – Apertures (GAR) 
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Graphical Aperture Reader – Parameters (GAR) 

 



 

Ucam Basic Training – Guide                          14 

Save .gar file 

 

Load .gar file 
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Wheel Editor 
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Auto Format 

 

Import Job 

 

Import a job from other CAM system. 

Quit 

Quit Ucam. 
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View menu 

Select… 

General 

 
 

Reverse 
Select all reverse apertures 
 
Chained 
Selects all draws and arcs in plane 1 connected to the one you click 
 
Painted 
Selects all areas where a combination of flashes, draws and arcs touch or overlap, to describe a large (copper) 
surface. 
 
Aperture 
Selects the objects using the current aperture in the Aperture List. 
 
Ref Layer 
Click Ref (reference) Layer to use selections on another layer (Plane 2) as a selection criterion 
 
Overlaps 
Selects all objects in all active layers that overlap objects in the reference layer, i.e. plane 2. 
 
Ape Definition 
Selects the objects using the current aperture and using an aperture definition identical to the current definition. 
 
Current Object 
The object being examined by Query Object is selected when you click Current Object. 
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Info 

 

Objects 

 
 

Shape 
Select objects with specified object shape. 
 
Object 
Select objects with specified object type. 
 
Without Pads 
Enables you to select electrical nets without any flashes. Netlist information must be available. 
 
Net 
Click on Net button and click on an object to select all objects belonging to the same electrical net. 
 
Testpoints/Net 
Select nets with a certain number of test points. 
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Contours 

 
 

PickContour : Picks all regions, all outer or all inner contours. 
All : Selects all regions, outers or inners in the active layers. 
Contour < : For every contour area in all active layers, UCAM calculates the X and Y size of the area's enclosing 
rectangle. If these sizes are smaller than the values you entered in the Contour fields, the area is selected. 
Surface < : Selects contours smaller than the specified area. 
Open : Selects all open contours in all active layers. 
Overlap : Selects all contours of the same aperture that overlap in all active layers. 
Ambiguous : Selects all ambiguous contours in all active layers. 
 

Rule Error Message  Selected object(s) 

1 Intersecting Shared Point The contour which has the shared point is 
selected 

2 Contour intersecting with contour of same 
aperture containing shared point 

The contour which has the shared point is 
selected 

3 Contour can be attributed to different 
intersecting parents of different polarity 

The inner contour is selected 

4 Contour can be attributed to different 
intersecting parents of same polarity and 
intersects with children of possible parents 

The enclosing box of the offending contour is 
marked using a diagonal line 

5 Small distance between Inner and Outer 

Small distance between 2 Contours  

The (almost) touching contours are selected 

6 Self-intersecting contour The self-intersecting contour is selected 
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Advanced 

 
 

Doubles Tol. 
Selects all doubles which have a difference in coordinates less then the tolerance value. Doubles are objects with 
identical shape and position. If more than two objects have the same shape and coordinates Doubles Tol selects all 
objects but one. 
 
Embedded Obj. 
Selects objects which are embedded inside other objects. You can use this function to find redundant objects that 
can be deleted without modifying the image. 
 
Length < 
Selects all draws which have a smaller length than the length indicated in the Length field. 
 
Ratio < 
Enter the ratio for the draw(s) to be selected. Ratio = draw length / aperture width. 
 
Ape > 
Select apertures with X and Y sizes larger than the specified X and Y values. 
 
Ape < 
Select apertures with X and Y sizes smaller or equal than the specified X and Y values. 
 
Isolated Flashes 
Select all flashes that are not connected to any other objects on the same layer. 
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Attributes 

 
 

 

History 

Choose History from the view menu to redisplay any of the last five views. 
Click repeatedly to scroll through the different views. 

Pan 

Choose Pan from the View Menu to view data adjacent to the current viewport.Repaint 

Zoom 

The Zoom submenu contains options for setting the enlargement factor by which data is displayed. 

Options 

The Options submenu contains options for setting the visibility of data, reference and zero points. 
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Grid… 

 
 

Select Grid from the View menu to define, display or hide a grid in the main drawing area. 
 

Guide… 

 
 

Choose Guide from the View menu to display the View Guide-dialog box. Use this dialog box to change the view on 
the data in the main drawing area. 
 
You can use the View Guide-dialog box to examine (specific parts of) the visible data to view for example the 
outcome of an action or to find selected objects. 
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Apertures Manager… 

 
 

Aperture Manager allows you to view and manage all apertures for the layer currently loaded in Plane 1. The name 
of this layer is displayed in the title bar. Loading a different layer in Plane 1 will automatically refresh the 
information displayed in the Aperture Manager dialog. 

Create Circle  
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Create Rectangle  

 

Create Box  
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Create Octagon  

 

Create Donut  
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Create Thermal  

 

Create Complex  
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Create Contour  

 

Create Text  
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Create Block  
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Edit Complex  

 

Edit Block  
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Load  

 
 

Load aperture from the selected DPF file and add them at the end of the aperture list 

Print  
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Errors… 
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Numbers… 

 
 

Point1 
Displays the coordinates of the first point indicated by a small cross. 
 
Point2 
Displays the coordinates of the second point indicated by a small cross. 
 
Center 
Displays the center coordinates between Point1 and Point2. 
 
Offset 
Displays the X and Y size of the enclosing rectangle. This is also the size of the job. Negative values are indicated   
by a right to left or an up to down offset. 
 
Distance 
Displays the distance between Point1 and Point2. 
 
Angle 
Displays the angle between the virtual line connecting Point1 and Point2. The angle is between -180 and 180 
degrees. CCW is the positive orientation. 
 
Clearance 
Displays the minimal clearance detected between Point1 and Point2. 
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Query Object… 
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Edit menu 

Cut 

Choose Cut to remove objects from the layer in plane 1 and puts them in the clipboard. 

Copy 

Choose Copy to copy objects (and their netlist information) from the layer in plane 1 to the clipboard. 

Paste 

Choose Paste to place the clipboard's contents into all active layers, even when they are in plane 0 (hide). 

Clear 

Clear the clipboard. 

Delete 

Delete all selected objects on activated layers. 

Apertures 

Clean 

Remove all unused apertures all aperture lists of all active layers 

Group Definition 

All objects that use a duplicate aperture definition are attached to the first aperture in the list which has this 
definition. 

Group number 

All objects that use a duplicate aperture definition and number are attached to the first aperture in the list which 
has this definition and number. 

Group Pos/Neg 

Minimize the number of polarity levels (i.e. positive and negative sections) in the Aperture List without changing 
the image. 
 

Replace 

Replace an object's aperture definition with the current aperture definition of the layer in plane 1. 
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Transform… 

On Reference Points : Enables reference points in the layer(s) to be shifted along with the objects. 
Use Center : Select 'Use center' to Use the Center of the X and Y coordinates as specified in the Numbers dialog 
box. 

Edit 

 
 

 Moves objects over relative distances to new positions in the same layer. 

 Copies objects within the same layer. 

 Drags vector starting or end points, to new locations. 
On Multiple Draws : Lengthens or shortens a number of parallel draws. You can also use Multi drag when you want 
to work on multiple vector points, located on different chains of vectors. 

  Mirrors objects along the X and Y axis. 

  Rotates objects in a layer. 

 Reverses an objects polarity. 

 Rotates objects in a layer. 
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Rescale 

 

Click [Set Origin] to change the Origin (zero point) of the job's layers. 

Click [Set Origin Center] to set the Origin (zero point) of the job's layers to the centerpoint. 

Click [Scale] to apply a proportional Scale factor to the DPF data. 
 
Register On Points : Click [Register On Points] to shrink, expand or distort a complete DPF layer. 
 
[Thicken] & [Thin] : Click on [Thicken] or [Thin] to make shapes larger or smaller. 
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BGA Tracks 

 

 Drags a draw maintaining the angle of its connection with two other draws. 
 
Min. Length : If during a Drag Constant Angle action one of the dragged lines becomes smaller than the specified 
length, dragging will not continue. Enter 0 if you do not want to specify a minimum length. 
 
Use limit : If during a Drag Constant Angle action using numbers one of the dragged line becomes smaller than the 
specified minimum length, dragging will not continue. 
 

 Makes equal space between selected draws using the outer two draws as reference. 
 

 Connects the draws from a Ball Grid Array to a selected draw. Select the required draws from the BGA and 
select the required draw. Clicking Drag to Line will connect the BGA with the draw. 
 

Chamfer : From  to  
 

Fillet : From  to  
 

Round : From  to  
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BGA Pads 

 

[Enlarge] : Starts the enlarge action 
 
Absolute : The longest side of the BGA pad will be enlarged using the specified absolute value (current unit). 
 
Relative : The longest side of the BGA pad will be enlarged using the specified relative value (%) 
 
exclude contour regions : Disables enlarge action on contours. 
 
only on BGA's (uBGA attribute) : Restricts enlarge action to objects that have the uBGA attribute set. 
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Insert 

Toolbox 

 

Insert > Flash 
 

 :To add a flash. 

 : To insert multiple flashes using step & repeat. 
 
Insert > Draw 
 

 : To insert a draw. 

 : To insert a draw with a pre defined angle. 

 : To insert a draw which is a bisector of 2 selected draws. 

 : To insert a number of connected draws. 
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 : To insert a draw as a tangent of 2 circles. 

 : To insert a draw as a tangent of an arc. 

 : To insert 4 connected draws in a rectangular shape (see Insert>Box) 

 : To insert a draw as an orthogonal draw with respect to a selected draw. 

 : To duplicate an existing draw as a parallel draw at a specified distance. 
 
Insert>Arc 
 

 : To insert an arc which is defined by 3 points (start, end and intersection point) 

 : To insert an arc which is defined by 2 points (start and middle point) 

 : To insert similar arc with smaller/bigger diameter 
 
Insert>Full Arc 
 

 : To insert a full arc. The radius of the arc can be set to a fixed value or can be set by dragging the mouse. 

 : To insert a full arc which is going trough 3 specified points. 

 : To insert a full arc in between 2 selected tangent lines. 

 : To insert a full arc in between 3 selected tangent lines. 

 : To insert similar full arc with smaller/bigger diameter 
 
Edit 
 

 : To modify the coordinates of an indicated object. 

 : To insert a break 
 
Delete 
 

 : To delete selected objects. 

 : To delete an indicated object. 

 : To keep the indicated segment of an object. 
 
Snap 
 
 

 : Deactivate any Snap mode or use hotkey x. 
Entering 1,2 or 3 on numerical keyboard will set snap plane color (sets outline color of "No Snap" button) 

 : Activate/Deactivate Snap to Grid. 
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 : Activate/Deactivate Snap to the endpoints of a line or arc. 
Selecting this option will deactivate the "Snap to virtual point". 
Activate the "Snap to Outline" toggle to snap to any corner of the outline. 

 : Activate/Deactivate Snap to the nearest object (arc or line). 
Activate the "Snap to Outline" toggle to snap to any point of the outline. 

 : Activate/Deactivate Snap to the center of a line or arc. 
Activate the "Snap to Outline" toggle to snap to any mid point of the outline. 

 : Activate/Deactivate Snap to the intersection of 2 or more objects. 
Activate the "Snap to Outline" toggle to snap to any intersection point of the outlines. 

 : Activate/Deactivate Plane Intersect & Object Intersect. 
Snap to any location where objects on a Data layer intersects with objects on a work layer. 
The work layer should have the same plane color as the outline of the Snap button. 
Activate the "Snap to Outline" toggle to snap to any intersection point of the outlines on Data and Work layer. 

 : Activate/Deactivate Snap to a virtual intersection point. Selecting this option will activate the "Snap to 
intersection" mode and deactivate the "Snap to Endpoints" mode. 
Activate the "Snap to Outline" toggle to snap to any virtual intersection point of the outlines. 

 : Activate/Deactivate Snap to outline mode. 
 
When deactivated, all snap actions apply to the skeleton view (default). 
When activated, all snap actions apply to the outline view. 
 
This toggle affects ALL snap modes (except snap to grid) 
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Vector Text… 

 

Barcode 39… 
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Reference… 

 
 
Reference is used to place a hot spot on a DPF, this point can be used later for outputting data. It is also used in 
combination of “Register On Points” for scanned data. 
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Undo menu 

Undo 

Choose Undo from the Edit menu to undo the last UCAM operation. 

Redo 

Choose Redo from the Edit menu to redo the operation which was last undone. 

Clear 

Choose Undo Clear from the Edit menu to clear the contents of the undo buffer. 

Options… 

 
 

[Undo] : Click Undo to undo the last UCAM operation which is displayed in the Undo field. 
[Redo] : Click Redo to redo the last UCAM operation which is displayed in the Redo field. 
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Verify submenu (Tools menu) 

Arcs… 

 
 

Use this dialog box to check all active layers for the presence of invalid arcs or (near) zero-length draws 

Copper Repair… 

. 
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SmartDRC… 
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Layer Rules 
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Layer-Layer Rules 
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Net Compare 

 

Choose Net Compare from the Verify submenu to compare a job's current netlist information for electrical 
changing (golden reference). 

 

Object Compare… 

 
 

Choose Object Compare from the Verify submenu to display the DPF Object Compare dialog box. Use this dialog 
box to check for changes to individual objects in the DPF data. Each object in the active layers of the current job is 
compared with the corresponding object on the same layer in a reference job. Depending on the checks you have 
activated, changes to the object's characteristics are reported as errors in the Error handling dialog box. 
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Image Compare… 

 
 

Choose Image Compare from the Verify submenu to display the Image Compare dialog box. Use this dialog box to 
optically inspect a complete job against a reference job or one layer against a reference layer. 
 
Image Compare can verify complete job against a reference job, or verify any kind of layer (copper, drill, rout 
paths, soldermasks, paste layers, silk screens,..) against a reference (dpf) layer. 
 
The outcome of an Image Compare process is an error list. The errors in this list can be viewed with the functions 
in the Error Handling dialog box. 
 
All differences can be saved as an *.ufd file and loaded again later. 
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Editing submenu (Tools menu) 

Clipping… 

 

Connect… 

 
Choose Connect from the Editing submenu to display the Connect Pad Track dialog box. Use this dialog box to 
connect pads and tracks that are close enough to one another. 
 
Active Radius : Defines which pads and tracks should be connected to each other. The connection takes place 
when the pads and tracks are closer to each other than the active radius. 
The new track is drawn with the smallest aperture (of the two endpoints) or a new circular aperture  (with the size 
of the smallest pad) is used if the two pads are non draw apertures. 
Snap Radius 
The snap radius defines how these pads and tracks should be connected. If the distance between the end points is 
smaller than the snap radius, one of the end points snaps to the other. If the distance between the end points is 
larger than the distance specified then a new vector is created to close the gap. Note that Snap radius is ignored 
when tracks are in a direct line with each other: in this case one of the two tracks is lengthened by dragging its end 
point to the end point of the other track (no connecting draw is added). 
The Snap Radius should be smaller than the Active Radius. 
Use Netlist 
When the toggle is activated, only objects which have identical and valid netlist numbers can be 
connected.  Objects for which there is no valid netlist info available will provoke an error message and will be 
disregarded. 
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Contours… 

 

Expand… 
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FlashMaker… 
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Setup 

 
 

Min Cutoff field 
Enter a value in the Min Cutoff field to define the minimum size of the cutoff corner of a model. A model with 
cutoff corners larger than Min Cutoff remains a box with rounded corners and a model with cutoff corners smaller 
or equal than Min Cutoff is converted into a rectangle. 
A value of 0 means that only those painted models that are perfect rectangles are converted to rectangular 
apertures. 
 

 
Min Size field 
Enter a value in the Min Size field to define the minimum size of the enclosing rectangle of the models to be 
converted. Models eligible for replacement that are smaller (in the x-direction or in the y-direction) than the 
minimum size are not converted. 
A value of 0 means that you should convert all (or selected) painted models smaller than the maximum size (see 
below). 
 
Max Size field 
Enter a value in the Max Size field to define the maximum size of the enclosing rectangle of the models to be 
converted. Models eligible for replacement that are larger (in the x-direction or in the y-direction) than the 
maximum size are not converted. 
Example: 
A value of 200 mils, means that anything over 200 mils is not considered by FlashMaker. 
 
Tolerance 
Deactivate Tolerance to use the best tolerance. This tolerance is determined based on the painted data. This is the 
default. 
Activate Tolerance to use the tolerance value specified in the Tolerance field. 
While converting, a small difference remains between the painted models and the flashed models. Only the 
conversions that have a difference smaller than the indicated tolerance are completed. 
 
Use Masks 
Limit find/replace only to objects in signal layers which are (partially) free of mask. 
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Deselect Nonmodel 
Searches for models in 'selected data` only. Objects not belonging to model instances are deselected. 
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Flip Job… 

 
 

Flip Job Buildup 
Flips the entire job as one, and not each layer separately. Therefore the first layer becomes the last and so on. 
Non attached layers are not flipped and preserve their order in the buildup. 
 
Flip Attach `None' 
Flips the extra layers with `None' attachment. 
Normally the extra non-attached layers are not flipped. 
 
Rename 
Adds the extension specified in the Rename field to the flipped layers. The flipped layers lose the extension when 
they are flipped back to their original position 

 

Models… 

 
 

Tolerance 
After clicking Select, "UCAM" selects instances of the defined model using a tolerance. This tolerance is derived 
from the length of the tracks in the model. 
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Register… 

 
 

[On Grid] 
Snaps all selected objects within the (rectangular) action area of a grid point to the grid. The action area is defined 
in the Radius X and Radius Y fields. All other objects are left at their original position. 
 
[On Pads] 
Pads in the active layers are registered to the nearest flash point of corresponding pads on a layer in plane 2.  
If the size of the pad on plane 2 is more than 3 times the size of the pad to be registered, registration will be done 
on the closest of 3 points : 

Flashpoint 
Start position of a virtual track covering the pad on which to be registered 
End position  of a virtual track covering the pad on which to be registered 

Tracks are offset with the average offset of the pads. 
 
On Pad Flashpoint 
Activate this toggle to register on flashpoint only. 
 
[Align Layers] 
Adjusts the relative position of all active layers using translations, rotations and mirroring. A report on the result of 
the registration appears in the startup window. 
The reference layer for the registration is defined with the following priority: 
The reference layer is the active layer in Plane 3 is taken first. 
The leftmost drill layer in the Job Editor is the reference layer if there is no active layer in Plane 3. 

 

Reverse Layer 

Choose Reverse Layer to reverse objects on all active layers (that are strictly positive). 
The outline layer is used to determine which objects to reverse. Objects residing inside the outline layer are 
reversed. 
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Tooling submenu (Tools menu) 

 Rout… 

  
 
Parameter Set 
Enter new Parameter Set name or select existing Set from drop-down list 
 
Reconstruct Arcs 
Expanded arcs are reconstructed when they contain draws smaller than a specified value. 
 
Validate Arcs 
Automatic replacement of invalid arcs by valid ones. 
 
Remove Small Objects 
- Objects smaller than the specified value are removed. 
- Objects which length is smaller than two times the aperture size are detected and connected. Connecting objects 
are trimmed if necessary. 
 
Connect Objects 
Connect all objects in a chain if they are not connected within a specified tolerance. 
Vectors which are not connected are, where possible, changed in length until they connect. 
 
Remove Redundant Objects 
Removes all objects which are no longer needed. 
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Distort… 

 

Drill Map… 

 
 
 
 



 

Ucam Basic Training – Guide                   61 
 
 

Fill Pattern… 

Fill with Pads  

 

Fill with Tracks 
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Fill with Starburst 

 

Fill Vector… 

 
 

Overlap 
The minimum overlap between two adjacent draws. 
 
Diameter 
The diameter of the smallest aperture used for filling. 
 
Ape Count 
Maximum number of apertures that can be used for filling. 
For each new aperture, the diameter is doubled. So, if you enter 4 and the smallest aperture is 2 mils, the filling 
algorithm uses 2 mil, 4 mil, 8 mil and 16 mil apertures. 
 
Ape Num 
Lowest number that may be used as aperture number for newly created apertures. 
 
Complexes, Thermals, Text, Boxes, Donuts 
If complexes, thermals, text, boxes and/or donuts also have to be filled, activate the corresponding toggle. 
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Shave… 

 
 

Silk Optimize…  
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Soldermask… 
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Teardrop… 
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Panel submenu (Tools menu) 

PanelPlus... 
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PanelPlus Results 
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StepRepeat…  

 
 

Middle 
Takes the center of the enclosing box of the job as flash point of the block. 
 
Job Zero 
Takes the zero point of the job as flash point of the block. 
 
Center 
Takes the center coordinates from the Numbers dialog box as flash point of the block 
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Output menu 

Drill/Rout: Machine… 

 

Edit Tools 
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CAD…  

 

Extended Gerber 
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Setup 

Ucam.db 
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Toolbars… 

  

  



 

Ucam Basic Training – Guide                   73 
 
 

Layers menu (Job Editor) 

Add DPF 

Choose Add DPF to display the File Select dialog box. Use the options of the File Select dialog box to add a DPF file 
to your current job.. 

Create 

Choose Create to create a new DPF layer within your current job. This layer can be either of class LAYER, DRILL, 
EXTRA or FEEDBACK, depending on where and how the layer is inserted into the cross section area.. 

Modify 

Layer 

 
 

Subclass menu 
UCAM comes with the following predefined subclasses for the main layer class LAYER: outer, inner, mixed. 
 
Reverse Data 
When this toggle is switched on, it indicates that the image you see in Ucam is reverse to the image of the 
produced PCB. You may want to execute the Reverse Layer command on such a layer.  
 
 
Material 
Displays the material used in the main layer class LAYER. 



 

Ucam Basic Training – Guide                          74 

 
Position 
Contains the layer number. Enter another number to change the position of the layer in your job. 
 
Z-Position 
Displays the layer's physical position (seen from top to bottom) in the PCB. 
The Z-axis for a job goes from top (lowest positive value) to bottom. The Z-Position is used in copper area 
calculations. 
 
Thickness 
Displays the copper thickness of the main layer class LAYER. The layer thickness is used in copper area calculations. 
 
Readable Side 
The readable side is displayed by an arrow indicating the direction in the cross section area. 

 

Extra 

 
 

Reverse Data 
When this toggle is switched on, it indicates that the image you see in Ucam is reverse to the image of the 
produced PCB. You may want to execute Reverse Layer command on such a layer.  
 
Material 
Displays the material of the main layer class EXTRA. 
 
Index 
Displays the index information for the guideplates subclass only. 
 
Attach 
Top : Extra layer is attached or related to the top layer. 
Bottom : Extra layer is attached or related to the bottom layer. 
None : Extra layer is not attached to any layer. 

Drill 
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From Layer 
Displays the layer number of the layer where the drilling begins from. Enter another layer number if you want 
another layer to be in the From Layer for this drill layer. 
 
To Layer 
Displays the layer number of the layer that is drilled to. Enter another layer number if you want another layer to be 
in the To Layer for this drill layer. 
 
Thickness 
Displays the copper thickness of the main layer class DRILL. The layer thickness is used in copper area calculations. 

 

Merge 

 
 

Positive 
The polarity of the layer(s) to be merged remains as it is. 
 
Negative 
The data in the layer(s) to be merged is reversed before it is put into the layer in plane 1. 
 
Alternate 
The first positive active layer to be merged remains as it is, the next one is reversed, and so on. 
 
Delete Merged Layers 
The layers that have been merged into plane 1 are deleted from the job. 
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Buildup menu (Job Editor) 

Load… 
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Support 

The UCAM help desk offers support in English, German, French and Dutch 

Availability:  
Monday – Thursday: 09:00 – 17:00 
Friday: 09:00 – 16:00 

Tel.:  +32 9 216 99 00 
Fax:  +32 9 216 99 12 
Email:  support@ucamco.com 

 

mailto:support@ucamco.com
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