ニュース

Apache log4j official statement

Recently you may have read about a potential security issue in the Apache Web Server software and as you may know, Ucamco uses Apache in both its Integr8tor and iamcam workflow solutions. As we are deeply concerned with the safety and security of our software products, we have investigated this matter in depth and we would like to inform you of our findings. 

After a thorough analysis of the nature of this Apache vulnerability CVE-2021-44228 with its log4j module, Ucamco state that standard installations of its Integr8tor and iamcam products are not affected by this vulnerability. The issue is related to the JNDI features on particular versions of the log4j module and Ucamco does not use JNDI functionality in its workflow products. Moreover, the affected versions of the Apache module have never been deployed in any customer software release. Therefore your Integr8tor or iamcam product is secure and can continue to be used in full confidence

 

Description of the vulnerability:

Apache Log4j2 <=2.14.1 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.15.0, this behavior has been disabled by default. In previous releases (>2.10) this behavior can be mitigated by setting system property "log4j2.formatMsgNoLookups" to “true” or it can be mitigated in prior releases (<2.10) by removing the JndiLookup class from the classpath (example: zip -q -d log4j-core-*.jar org/apache/logging/log4j/core/lookup/JndiLookup.class).